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SCRIPTING THE WEB – PART 1 - 

INTRODUCTION TO JAVASCRIPT – EXERCISE 1 – CREATING AND USING A FUNCTION
JavaScript is one of the most important languages used in web development. It has many uses ranging from checking the values submitted by forms to controlling interactive widgets, such as tabbed panels, accordions and flyout menus.  It's also used to create photo galleries, and to fetch new information from the web server to refresh content without the need to reload the page - a combination of technologies commonly known as Ajax.
Along with HTML and CSS, knowledge of JavaScript is a key skill that anyone involved in building websites should acquire.  Yet many web designers never do.  JavaScript has a reputation for being too difficult; and graphic designers frequently insist that their role is to design, not to program.  Even if you never do any JavaScript programming yourself, it's important to understand how the structure of your web pages affects the job of the JavaScript programmer.  What's more, JavaScript has become easier to use thanks to code libraries such as jQuery.
What is JavaScript and what is it for? 

In spite of the similarity of names, JavaScript is not Java.  The languages are not related.  Java is frequently used to program games, mobile phones, and other devices, such as the Amazon Kindle.  Although Java can be used in websites, it's rarely used that way.
JavaScript, on the other hand, is a lightweight, yet powerful language that normally runs inside a web browser.  Its role is to provide access to different elements of the page so that they can be removed or updated.  It can also create new elements, change the style of existing elements, or extract information from them.  For example, it can read the values entered into a form, perform a calculation, and display the result.  It can also send a request to the web server for more information, and update part of the page without needing to reload it.
JavaScript performs these tasks by accessing the Document Object Model (DOM).  The DOM is a structure similar to a family tree.  If the HTML markup of your page is invalid or too complex, the JavaScript code can't navigate the family tree.  Similarly, if you break simple rules, such as using the same ID more than once in any page, JavaScript becomes confused and simply gives up.
The importance of events 

JavaScript is an event-driven language.  Some events are triggered automatically.  For example the load event is triggered when the page finishes loading in the browser, and it's frequently used to initialize flyout menus and other widgets.  Other events are triggered by the user, the most common being the click event when the user clicks the main mouse button, or taps on a touch-sensitive screen.  Other common events include mouseover and mouseout, when the user hovers over an element, and submit, when a form is submitted.
Events are being triggered all the time.  An event is triggered every time you move the mouse, scroll the page, or press a key.  It would be chaos if the browser had to respond to every event.  Instead, you as the developer, create functions to handle specific events, and you associate them with the page elements that you want to respond to the event.  This is known as binding an event handler.
Event handler functions sit and wait - or listen - for the event.  When the appropriate event is triggered, the event handler jumps into action and performs its designated task, such as opening or closing a flyout menu, submitting a form, or changing the style of an element.
Creating a function 

Rather than talk in abstract terms, let's look at JavaScript in action.
As the name suggests, a function does something. It's a series of commands that performs whatever task (or tasks) you tell it to do.  The most common way to define a function is to use the keyword function followed by the function name, a pair of parentheses, and a block of code wrapped in curly braces.  

You can give functions almost any name you like, but it must begin with a letter, underscore (_), or the dollar sign.  Also, the name must not contain any spaces or hyphens.  JavaScript is case-sensitive, so it's common to give functions descriptive names using an uppercase letter for the second and subsequent words ("camel case"); for example, changeFontSize.
To keep the code as simple as possible, the following example just changes the text size of an unordered list.  

1. Create a new folder in your MySites folder called Web_Scripting-Part1. 
2. Define a new Dreamweaver site called Web_Scripting-Part1 and set the root folder as the Web_Scripting-Part1 folder that you have just created.  Equally, the exercise can be completed using Notepad++.
3. Create a new HTML page and save the page as change_start.html.

4. In Code view, enter the following code:

<!DOCTYPE HTML>

<html>

<head>


<meta charset="utf-8">


<title>Changing Font Size</title>

</head>

<body>


<h1>A Fascinating List</h1>


<ul id="fruits">

  

<li>Apples</li>

  

<li>Pears</li>

  

<li>Oranges</li>


</ul>


<p>Change list font size.</p>

</body>

</html>
5. The page contains an <h1> heading, an unordered list, and a paragraph.  The unordered list has the ID fruits.

6. Save the web page change_start.html and view the page locally in a browser.  The page should appear as follows:
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A JavaScript function will be used to change the list's font size. 
7. In Code view, insert a new line just before the closing </head> tag, and add a <script> tag.  The page has an HTML5 DOCTYPE, so you don't need to add type="text/javascript".  Browsers automatically assume that the code inside a <script> block is JavaScript.
8. Before adding the JavaScript code, it's a good idea to close the <script> block. Therefore, leave a blank line and then type </script>. 
9. Inside the <script> block, enter the following code:

function changeFontSize() {


}

This defines a function called changeFontSize().  You often pass information as arguments to a JavaScript function.  The arguments go between the parentheses after the function name.  This function doesn't take any arguments, but the parentheses must still be used.  The body of the function goes between the curly braces.  You'll add that next.

10. Type var list = document on the line between the curly braces.  Then type a period (a full stop) immediately after "document."  As soon as you type the period, recent versions of Dreamweaver display a list of code hints.
11. Type g.  This brings up the code hint for getElementById().  Press Enter/Return to insert the code.
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12. Dreamweaver presents another code hint informing you that getElementById() expects an ID as its argument.  Type a quotation mark (single or double, it doesn't matter).  If you're using Dreamweaver CS6, it automatically presents you with a list of IDs on the current page.

13. In Dreamweaver CS6, press Enter/Return to insert the fruits ID.  Then type a closing parenthesis followed by a semicolon. 
If you're using another program, you need to complete the code manually.  In either case, you should now have the following code in your function definition:
<script>


function changeFontSize() {



var list = document.getElementById('fruits');


}

</script>

The line of code you have just typed uses the keyword var to create a variable called list, which stores a reference to the page element with the ID fruits.  The reference to fruits is obtained by a JavaScript method called document.getElementById().
Note: Methods are essentially the same as functions, except that they belong to objects.  You'll learn about objects later.  Don't let the terminology confuse you.  If it helps, just think of a method as being a special type of function.
14. Insert a new line after the one you just typed, and add the following code:
list.style.fontSize = '20px';

If you're using a recent version of Dreamweaver, you'll have noticed code hints popping up each time you typed a period.  What this line of code does is change the size of the text in the list element -in other words, the unordered list with the ID fruits.
You probably recognize fontSize as similar to the CSS font-size property.  JavaScript doesn't allow hyphens in names.  So, the hyphen is removed and the word after the hyphen is capitalized.
The complete function definition should now look like this:


function changeFontSize() {



var list = document.getElementById('fruits');


list.style.fontSize = '20px';

}

15. Save the page as change_01.html and test it in a browser.  Nothing happens.  Although you have defined a function, it doesn't do anything until it's triggered by an event.  You'll create an event handler for it shortly, but first take a look at some important features of JavaScript that this short piece of code has introduced you to.

JavaScript Basics 

If you have experience with other programming languages, most of this section should be familiar.  But for the benefit of complete beginners, we’ll explain the basic terminology.  At first, it might seem like jargon overload, but it will make the rest of this exercise easier to follow.
The first line inside the changeFontSize() function definition creates a variable called list.  Variables are an important part of all programming languages.  A variable usually stores a value that you don't necessarily know in advance.  The name of the variable remains the same, but its value might change.  To take an example from everyday life, your bank balance is similar to a variable. The amount changes frequently, but the name "balance" always remains the same.
When defining a variable inside a function, you should always use the var keyword.  Doing so tells the JavaScript engine that you want the variable to be used only inside the function.  Omitting var can produce unpredictable results in more complex scripts.
The same rules apply to variable names as to functions, namely:

· The name must begin with a letter, underscore, or the dollar sign.

· No spaces or hyphens are allowed.
The value is assigned to the variable using an equal sign.  The value on the right of the equal sign is assigned to the variable on the left.
The first line in the changeFontSize() function uses document.getElementById('fruits') to assign the variable a reference to the fruits unordered list.  This introduces you to three important features of JavaScript - objects, dot notation, and passing arguments to a function.
In simple terms, an object is a variable that contains zero or more other values known as properties and methods.  A property is similar to variable, and a method is essentially the same as a function.  You access the properties and methods of an object using dot notation.  The object comes first, followed by a dot or period, and then by the property or method.  In this case, getElementById() is a method of the document object.
The method getElementById() is self-explanatory.  It gets a reference to an element using the element's ID.  You put the ID in quotes between the parentheses after the method's name.  This is known as passing an argument.  Because the argument is in quotes, JavaScript treats it as literal text.  In programming terms, literal text is known as a string (because it's a string of characters).  It doesn't matter whether you use single or double quotes for strings, but the quotes must match.
The second line in the changeFontSize() function takes dot notation a step further. It accesses the style object of the element stored in the list variable, and then accesses its fontSize property like this: list.style.fontSize.  The value assigned is a string containing the new size.  In other words, the second line sets the CSS font-size property of the fruits list to 20px.
There's one final point to notice.  Each command ends with a semicolon. Technically speaking, the semicolon is optional, because JavaScript automatically treats the end of a line that contains a command as the end of the command.  If you accidentally break a line of code, JavaScript treats it as a complete command, causing your script to fail.  Always ending commands with a semicolon makes errors easier to find.
That's enough theory for now. Let's get back to the code and make the function do something.
Using the function

The simplest way to use a function is to bind it to an element using an HTML attribute, such as onClick.
16. Open the web page change_01.html, and still in Code View, select the text in the final paragraph, and type javascript:; in the Link field of the Property Inspector in HTML mode. This adds a dummy link to the text.

17. Insert a space before the closing angle bracket of the opening <a> tag.  Then type onClick="changeFontSize()".  The final paragraph should now look like this in Code View:
<p><a href="javascript:;" onClick="changeFontSize()">Change list font size</a>.</p>

18. Save the page as change_02.html and view the page in your browser (or activate Live View in Dreamweaver).
19. Click the link in the last paragraph (if you are in Live View, hold down the Ctrl key on Windows or the Command key on a Mac while clicking).  If your code is correct, the text in the list increases in size:

[image: image4.jpg]



[image: image5.png]] Hiunit 20 - Cnt 5 v

i Favorkes (28]~ [« | @changi.. x

A Fascinating List

« Peas
+ Oranges

Change st font size.

T s

-

 100%





Detecting errors when your script doesn't work

We all make mistakes and you tend to make a lot when you're learning a new subject.  If there's a problem with your code, the script usually fails without any indication of what went wrong.  All recent browsers have built-in tools to help you debug your code.  You can find them in the following locations:
· Internet Explorer 8 or later:  Press F12 to open the Developer Tools and select the Console tab.

· Firefox 4: Select Web Developer > Error Console.

· Google Chrome: Select Tools > Developer tools.

· Safari: Enable the Developer menu by selecting Edit > Preferences (Windows) or Safari > Preferences (Mac). In the Advanced tab, select "Show Develop menu in menu bar."  Close Preferences. Then select Develop > Show Error Console.

· Opera: Select Tools > Advanced > Error Console.

20. Now, you will Introduce a deliberate mistake into the changeFontSize() function to see the error message generated by the browser's error console.  Change the spelling of getElementById() to use an uppercase D like this: 
var list = document.getElementByID('fruits');

21. Save the page change_02.html, and reload it in your browser.  (You can't use Live View for debugging).
22. Click the link in the final paragraph.  The list's font size doesn't change.
23. Open your browser's error console.  You should see a message similar to the one below:
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The error messages generated by your browser might be worded differently, but they all basically say the same thing: getElementByID() isn't a valid function.  As a beginner, working out why an error occurs isn't always easy, but one of the most common mistakes is misspelling the name of a function or method.  JavaScript is case-sensitive.
All error consoles, except the one in Opera, provide a link, which takes you to the line that contains the error.
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